
User Supported Software
This program is produced by a member of the Association of Shareware Professionals (ASP).
The ASP wants to make sure that the Shareware principle works for you.    If you are unable 
to resolve a Shareware-related problem with an ASP member by contacting the member 
directly, the ASP may be able to help.    The ASP Ombudsman can help you resolve a 
dispute or problem with an ASP member, but does not provide technical support for 
members' products.    Please write to

ASP Ombudsman
545 Grover Rd
Muskegon, MI      49442

or send a CompuServe message via CompuServe mail to the ASP Ombudsman at
70007,3536

See also Definition of Shareware, Disclaimer - Agreement.



Definition of Shareware
Shareware distribution gives users a chance to try software before buying it.    If you try a 
Shareware program and continue using it, you are expected to register.    Individual 
programs differ on details ... some request registration while others require it, some specify
a maximum trial period.    With registration, you get anything from the simple right to 
continue using the software to an updated program with printed manual.
Copyright laws apply to both Shareware and retail software, and the copyright holder 
retains all rights, with    a few specific exceptions as stated below.    Shareware authors are 
accomplished programmers, just like authors of retail software, and the programs are of 
comparable quality.    (In both cases there are good programs and bad ones!)    The main 
difference is in the method of distribution.    The author specifically grants the right to copy 
and distribute the software, either to all and sundry or to a specific group.    For example, 
some authors require written permission before a commercial disk vendor may copy their 
Shareware.
Shareware is a distribution method, not a type of software.    You should find software that 
suits your needs and pocketbook, whether it's retail or Shareware.    The Shareware system 
makes fitting your needs easier, because you can try before you buy.    And because the 
overhead is low, prices are low also.    Shareware has the ultimate money-back guarantee ...
if you don't use the product, you don't pay for it.
See also Disclaimer - Agreement, User Supported Software.



Disclaimer - Agreement
Users of this program must accept this disclaimer of warranty:

The Humor Mill is supplied as is.    The author disclaims all warranties, 
expressed or implied, including, without limitation, the warranties of 
merchantability and of fitness for any purpose.    The author assumes no 
liability for damages, direct or consequential, which may result from the use of
The Humor Mill.

This program is distributed as Shareware and is provided at no charge to the user for 
evaluation.    Feel free to share unaltered copies of it with your friends.    The essence of 
"user-supported" software is to provide personal computer users with quality software 
without high prices, and yet to provide incentive for programmers to continue to develop 
new products.    If you find this program useful and find that you are using it and continue to
use it after a reasonable trial period, you must make a registration payment of $30.00 (US 
funds) to The Software Construction Company.    Massachusetts residents must include 5% 
for sales tax.    This registration fee will license one copy for use on any one computer at 
any one time.    You must treat this software just like a book.    An example is that this 
software be used by any number of people and may be freely moved from one computer 
location to another, so long as there is no possibility of it being used at one location while 
it's being used at another, just as a book cannot be read by two different persons at the 
same time.
Commercial uses of this program must register and pay for their copies within 30 days of 
first use or their license is withdrawn.    Site-License arrangements may be made by 
contacting The Software Construction Company.
Anyone distributing this program for any kind of remuneration must first contact The 
Software Construction Company for authorization.    This authorization will be automatically 
granted to distributors recognized by the Association of Shareware Professionals as 
adhering to its guidelines for Shareware distributors, and such distributors may begin 
offering this program immediately (however, The Software Construction Company must still
be advised so that the distributor can be kept up-to-date with the latest version).
You are encouraged to pass a copy of this program along to your friends for evaluation.    
Please encourage them to register their copy if they find that they can use it.    All 
registered users will receive a copy of the latest version of the program.
If you have received this software through one of the so called "Shareware Houses" 
(companies whose business is selling diskettes containing other authors' software), please 
note that none of the money you have paid so far has (or will) make its way to the author.    
You have simply paid for the duplication and distribution costs.
See also Definition of Shareware, User Supported Software.
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Creating a New Database
Creating a database to contain jokes is as simple as choosing the "New Database ..." 
selection from the "File" menu.    After you specify a name for the newly created database, 
you may begin to fill it with your favorite jokes.
Don't worry about what jokes get put in what database.    By using the Append and Export 
features of The Humor Mill, you can change your mind and regroup your collection later.



Database Basics
The Humor Mill operates on standard DBASE IV files containing the joke data.    To perform 
any operation within the program, you must have a database loaded or create a new one.
Use a database to categorize a collection of jokes.    Don't worry too much about the 
category you choose for a database, you can always change your mind later and move 
jokes or whole databases around using the Append and Export features of The Humor Mill.
If you wish to have a database containing all you jokes so that you may search all the jokes 
in your collection or have random jokes selected from the entire collection, just use the 
Append feature to append all the databases together.    Save it to a different name than any
other (e.g., ALLJOKES.DBF) and you can still keep your databases categorized.    It's the best
of both worlds, so to speak.



Loading a Database
To load an existing database into The Humor Mill, choose the "Open Database ..." selection 
from the "File" menu.    A dialog box will appear listing all the DBASE IV files in the current 
directory.    You can use this dialog to browse through different directories until you find the 
database you are interested in loading.
After selecting the database, you will see that the main window will become a list of jokes 
from the database that was just loaded.    See Telling a Joke for information on displaying 
jokes.



Startup Options
To have a database loaded automatically each time The Humor Mill is loaded, select the 
"On Startup ..." selection from the "Options" menu.    There are several settings that you 
can specify in the dialog that is presented:
Default Database
This setting specifies the database that will be automatically loaded upon startup.    You 
may type in the filename to load or use the "Browse ..." button to browse around your disk 
to select a file.
Tell Me One Joke Upon Startup
This checkbox indicates whether you wish to have a random joke presented from the 
default database whenever The Humor Mill is launched.
Note that this option has no meaning if there is no default database specified.
Tell Me a New Joke Every x Minutes
This checkbox indicates that you wish to have The Humor Mill wake up periodically and 
present you with another random joke.    How often it does this is entirely up to you.    
Perhaps if you are having a particularly trying day, you should set it to be more frequent!
Note that this option does have meaning even if there is no default database loaded.    The 
random joke will be presented from whatever database you have loaded.    You could have 
the default database be G-rated and then load the R-rated database at lunchtime to get 
more risqué jokes in the afternoon.



Saving Changes to a Database
If you make any changes to the loaded database (see Loading an Existing Database or 
Creating a New Database for more information about how to do that), you will need to save 
the changes to be able to see them in the future.
You can always tell if you need to save the database as "Modified" flag will appear in the 
status bar along the bottom edge of the joke list window.
To save the changes you've made to the database, select the "Save Database" entry under 
the "File" menu.    This will save the database using its current name.    If you would like to 
save it as a different name (that is, you'd like to keep the original database intact), use the 
"Save Database As ..." entry under the "File" menu.
You needn't fear leaving the program inadvertently and losing your changes, either.    If you 
try to leave the program with the "Modified" indicator visible, The Humor Mill will inform 
you that you have unsaved changes and ask if you'd like to lose them.    If you answer 
"Yes,"    the changes will be lost and the contents of the database will be what they were 
the last time you saved (or what they were when the program was launched if you had 
never saved).    If you answer "No," you will be returned to the program.    Note that 
answering "No" does NOT save the database; you must do that explicitly after you return 
to the program if you wish to keep any changes.



Adding a Joke
Besides using the databases that come with The Humor Mill, you can keep track of your 
own jokes, funny stories, etc.    You can add them to our databases or you can create new 
databases to hold yours.    It is probably easier in the long run to put your jokes in separate 
databases as you may wish to upgrade your program in the future and we will definitely be 
making additions and improvements to our collection of databases.    Of course, if you've 
already started making additions to our databases, you can always change your mind and 
use the Export feature to copy any individual jokes you'd like to a different database.
To add a new joke, you must have loaded the database into which you'd like the joke to go.  
See Loading Databases for more information.
Use the "New Joke ..." entry on the "File" menu to add a new joke.    A dialog will be 
presented that allows you to make entries for any or all of the fields in a joke record.    The 
fields that you may give values for are:

Joke Type
Joke Title
Joke Text
Memo

You needn't specify a value for any of the fields, but some of them make more sense to 
leave blank than others.    For example, you may not have any memo information at the 
present time, but there is probably little reason to leave the Joke Text field blank and it will 
be harder to find your Joke again if the Joke Title field is left blank.
Fill in all the fields with the information for your joke and select the "SAVE" button.    Should 
you change your mind and not wish to add this joke after all, select the "CANCEL" button.
Notes:
The Type field is a list box of any joke types we've supplied as well as any user defined 
types.    Select the one that best describes the type of joke you are entering.    If none of 
them adequately describe your entry, see User Defined Types for information about adding 
a different one.    We'd also like to know what type of joke we neglected to include, so 
please contact us.
The Text and Memo fields can contain multiple lines of text.    Your lines will automatically 
be folded as you type them in.    You can, of course, put in your own carriage returns, but 
your jokes will not be formatted correctly in other dialog boxes or if you print them.
All the fields except the Type field can be checked with the built-in spelling checker.    The 
spelling checker is not available in the evaluation versions of The Humor Mill.



Editing a Joke
To edit (or change) a joke, select the joke from the joke list and then use the "Edit Joke" 
entry in the "File" menu to bring up a similar dialog to that which was used to add the joke 
originally.    Make any changes you'd like to any of the fields.    Use the "SAVE" button to tell 
The Humor Mill to remember your changes.    If you change your mind, use the "CANCEL" 
button to discard any changes.
Note that you will still have to Save the Database to make sure the changes are written into
the database permanently.
See Deleting a Joke for more information about getting rid of any jokes you no longer wish 
to keep.



Joke Types
One of the fields that accompanies each joke is its type.    This field is designed to make it 
easier to find just the right type of joke for any occasion.    For example, if you were giving a
speech, a limerick might not be appropriate.    You may be looking just for humorous stories.
If you'd like to trade jokes with your five-year-old, you may wish to examine only knock, 
knock jokes first.
We have preset the types to the following list:

Knock, knock
Limerick
List
Other
Pun
Ques & Ans
Quote
Story

We were not able to think of (nor had we come across) any other types as of the time of 
this release.
We did, however, include the ability to add your own types.    See Adding User Defined 
Types for more information.    If you do come across any sort of joke that we missed, please 
let us know as we may wish to make it a "Factory Type" in a future version.



Deleting a Joke
To remove a joke from a database, start by bring the joke up in the editing dialog (see 
Editing a Joke).    Instead of making changes and saving, use the "DELETE" button to get rid 
of it.
Note that you will still need to Save the Database in order to have the deleted record 
removed permanently from the database.



Adding User Defined Types
If you find that the list of "Factory Installed" types do not include one that you need, you 
can add others.    We ask that you contact us if you find the need to do this as we'd like to 
determine whether we need to include more types in the ones we predefined.
To add a new type, select the "Type Names ..." entry from the "Options" menu.    In the 
dialog presented after this selection, you will see a listbox containing the current list of 
defined types, both "Factory Installed" and User defined.    Type in the name of the new type
and use the "ADD" button to complete the operation.
If you've made a typographical error in a type name, select the type name with the mistake
from the list, type the corrected name in the New Name field and use the "RENAME" button 
to change it.
There is no way to remove types after they have been entered.    You may rename a type to 
"REUSE THIS" or some other string and reuse it the next time you wish to add a new type.



Checking the Spelling of a Joke
Note that this feature is not available in the evaluation versions of The Humor 
Mill.    If you need this feature, you will have to purchase a copy.    Not including 
this feature was done both to keep the size of the evaluation version 
manageable for downloads and also to offer an encouragement for customers to 
purchase The Humor Mill.    We hope you understand.
When editing a joke (see Editing a Joke for more information on how to do this), you can 
use the "Check Spelling" entry under the "Utility" menu to check the spelling of each of the 
text fields.    As each field (title, text, and memo) is completed, you will see a dialog box 
presented.    In other words, three separate dialog boxes will be presented as one joke is 
checked for spelling.



Moving Jokes Between Databases
Once a joke is entered in a database, you needn't enter it ever again, even if you need to 
have it in another database.    The Humor Mill offers the opportunity to move individual 
jokes from one database to another.    We call this Exporting a Joke.    The Humor Mill also 
offers the ability to concatenate two databases together.    We call this Appending a 
Database.



Appending one Database to Another
If you have two databases that you would like to combine in order to create a larger 
database with all the jokes from both, the Append feature will do exactly that.
Start off by loading one of the databases (See Loading a Database for more information on 
this) into the program.    You can also create a new database (See Creating a New Database 
for more information) and append all the databases to it.
Use the "Append Database ..." entry under the "File" menu and specify the database you'd 
like added to the end of the currently loaded database.    If you have other databases you'd 
also like added, keep using the "Append Database ..." entry under the "File" menu.
When you have finished specifying databases to append, you'll have to Save the Database 
for all changes to become permanent.



Exporting a Joke to Another Database
If you have a joke in one database that you'd like to add to another, use this feature.
To accomplish the task of copying the joke into an external database, you have to have 
loaded the database containing the joke in question.    See Loading a Database for more 
information on this.
Select the joke you want to export and bring it up in an editing dialog.    See Editing a Joke 
for more information on this step.
Select the "Export to Database ..." entry under the "File" menu and you will be able to 
specify the database into which the joke record should be copied.



The Software Construction Company
We may be reached via mail at

PO Box 160
North Billerica, MA    01862-0160
USA

We may also be reached via phone (voice or FAX, 24 hours per day) at
        (508) 851-6204
Our phone system is capable of accepting Mastercard or Visa orders as well.
We may also be reached electronically via one of the following addresses

CompuServe 70313,3615
Internet softcons@world.std.com



The Association of Shareware Professionals
You may contact the Association of Shareware Professionals via mail at

545 Grover Rd
Muskegon, MI    49442-9427
USA

Or via phone at:
(616) 788-5131
(616) 788-2765 FAX



Joke Type
This field is intended to tell what sort of joke this is.    It is useful to know if something is a 
story or a knock-knock joke, etc. if you might be looking for a joke for a speech or a paper.   
You can create your own joke types as well as use the ones we've included.
Note that each joke MUST have a type.



Joke Title
This field is intended to contain a short string that is displayed in the joke list to remind you
of the (perhaps) longer joke that is contained in the Joke Text field.    As with any field, it can
be left empty, but you may have a    more difficult time locating the joke again in the future.
This field can be checked for correct spelling when The Humor Mill is purchased.



Joke Text
This field contains the actual text of the joke.    You can leave this field empty, but why 
would you want to?
This field can be checked for correct spelling when The Humor Mill is purchased.



Memo
This field is for anything else that you might need to attach to a joke.    You could use it to 
categorize your jokes by subject (or you could separate them into databases of the same 
subject).    One use we have for this field is for an explanation if the joke is a pun (in case 
someone doesn't get it).
This field can be checked for correct spelling when The Humor Mill is purchased.



Sorting the Database
Notice the buttons above the joke list labeled "Num," "Type," and "Title."    Pressing one of 
these buttons will sort the joke list on that field.    By default, the list is sorted by number, 
but if you remember the title, sorting the titles alphabetically might be all that you need to 
scroll to it quickly.    Sorting by the joke type allows you to skip straight to the type of joke 
you remember it to be.



Finding a Particular Joke
There are several ways we've created to help you zoom in on a particular joke.
See Sorting the Database for a quick way to look at the entries in a different order.
We've also created a powerful search facility which will let you select only jokes matching 
your particular needs.    See Searching for a Joke for more information on how to use this 
feature.



Searching the Database
It's easy to search for jokes containing a particular string.    Select the "Search ..." entry 
under the "File" menu.    The search dialog will appear.
There are two parts to the search dialog.
1. The main part of the dialog consists of pairs of entry fields.    These are used to specify 
the field and string for which you'd like to search.    For example, if you want to see jokes 
with "terrific" in the memo field (a mark you may have put there to show your favorite 
jokes), you would select Memo in the left listbox and type terrific in the right edit box.
2. At the bottom is a pair of listboxes that will allow you to select which types of jokes you'd
like included.    For example, if you are giving a speech, you might be interested in looking 
only at stories or quotes.    Knock, knock jokes or Limericks might not be appropriate.
Note that the strings are not case sensitive.    In other words, searching for children will 
create exactly the same list as searching for CHILDREN or Children.
Only the jokes displayed in the joke list change when you do a search.    To get back to the 
full database, use the "Full Database" entry in the "File" menu.



Welcome to The Humor Mill
If this is the first time you have run our program, we at The Software Construction 
Company would like to thank you for using our product.    We are certain that you will find 
this a quality product and will be able to use the information for many years to come.
Since the information that The Humor Mill manages is jokes, we hope that you will find your
tour through our databases amusing as well as useful.    You can store your own jokes or just
use the program as a way to sort, search, categorize, or view those jokes that we've 
collected.
We ship three databases with The Humor Mill:

G-rated
PG-rated
R-rated

You must specifically select the R-rated database in order to install it.
What won't you find in The Humor Mill's databases?    You won't find any jokes that would be
considered X-rated.    We have found that it is not too difficult to modify an X-rated joke to 
make it R-rated.    You also won't find any topical jokes.    For example, jokes about a specific
US President might be funny for a while; perhaps a long while.    But eventually they would 
begin to be dated.    While we can't claim that each and every joke is a timeless gem, we 
strive to select jokes that will be funny for the longest time possible.
As you can imagine, we are always looking for new material to add to our collection of 
jokes.    If you know of a good joke, funny story, etc., we'd really like to hear it.    We do, of 
course reserve the right to accept or reject any submission without reason.
The evaluation version of The Humor Mill will work exactly like the purchased version for a 
period of 60 days or 60 uses, whichever is longer, with the following exceptions:

1. The spelling checker is not included with the evaluation version.
2. Upon startup, a screen will be displayed showing you how much of the evaluation 
period you've used and providing a button to help register the product.

After the trial period has elapsed, many functions in the program will cease to be available. 
You will still be able to look at any joke we've provided or you've added, but many of the 
other functions will be disabled.
See our address for ways to contact us.



Registering The Humor Mill
Registering The Humor Mill costs just $30.00 (US funds).    Massachusetts residents must 
include 5% sales tax.    Add an extra $5 if shipping outside of North America is required.

Registered users of The Humor Mill receive the following benefits:
Notification of any updates
The latest version of the software
A much more extensive collection of data
The ability to check the spelling of any joke in the database

Although we encourage copying and sharing of The Humor Mill, we must insist that 
registered users NOT share the larger databases.    We retain full copyrights to these files.    
It is an infringement of copyright law to distribute copies of these files.
You can, of course, register The Humor Mill directly from The Software Construction 
Company (click on our name for how to contact us).    We accept cash, checks, money 
orders, Mastercard and Visa.    Please specify 5¼ or 3½ diskettes (If you don't specify, we'll 
ship 3½ diskettes).    We have made this as easy as possible by providing a "Register" 
command under the Help menu.
We have arrangements with two companies to also accept credit card orders on our behalf:
Public (software) Library
PO Box 35705
Houston, TX      77235-5705
(800) 242-4775 Orders
(713) 524-6398 FAX
(713) 524-6394 Information and Help
CompuServe: 71355,470
will accept Mastercard, Visa, American Express, and Discover payments
BUDGETWARE
PO Box 496
Newtown NSW 2042
AUSTRALIA
(02) 519-4233
(02) 516-4236 FAX
will accept Bankcard, Mastercard, and Visacard.    Payment is $49 (Australian funds).
You can also register using CompuServe's® registration service (GO SWREG at any 
prompt).    Our product numbers are as follows:

Diamond Data #2063
On This Day for MSDOS #2074
On This Day for Windows#2093

See also Evaluation diskettes.



Evaluation Diskettes
For $5 (US funds) to cover our costs (refunded when you register), we will supply you with 
the latest edition of the software.    Please specify 5¼ or 3½ diskettes (If you don't specify, 
we'll ship 3½ diskettes).



Bug Reports
Should you discover a bug in this code, please let The Software Construction Company 
(click on our name for ways to contact us) know.    Please provide us with as much of a 
description of the problem as you can, as well as your name and address.    If you would 
prefer being contacted by phone, add your phone number and the hours we can reach you.



Known Problems/Limitations
None.



Bibliography
Coming soon.



Getting Output
There are three places you can direct a joke to go should you wish to use it outside The 
Humor Mill:
1. Use "Copy All" from the "Edit" menu to insert the joke into the clipboard.
From the clipboard, it can be pasted into virtually any other application.
2. Print the joke.
Use the "Print Setup" entry on the "File" menu to select the printer and its properties.    
Then select the "Print" entry on the same "File" menu to send the joke to the printer.
3. Send the text to a disk file.
The text of the joke can be sent to a disk file by selecting the "Output to a File ..." entry on 
the "File" menu.    You must specify a filename in the dialog that will be shown.    Upon 
successfully doing that, the file will be created and the text written to it.



Seeing a Joke
There are number of different ways to have a joke presented to you.

1. You can have The Humor Mill tell you a random joke.
2. You can ask to see a particular joke.
3. You can have a random joke presented periodically while The Humor Mill is 

running.
4. You can browse forward and back through the jokes.



Having The Humor Mill tell you a random joke
If you'd like to have your funny bone tickled, The Humor Mill can tell you a random joke 
from the collection contained in the loaded database.    There are a number of ways to do 
this:

1. Choose the "Tell me a Joke" entry under the "Display" menu.
2. Configure The Humor Mill to periodically display a random joke while it is running.
3. If you already have a joke displayed, use the "Random Joke" button.



Displaying a Particular Joke
To display a particular joke, you must first find it in the list of jokes.    You can, of course, 
scroll through the database looking for the title (if you remember it) or you can use the 
"Previous Joke" and "Next Joke" buttons once you've gotten any joke displayed.    A quicker 
way to "zero in" on that special joke is to use the powerful sorting and searching 
capabilities.
Double clicking the mouse on a joke in the joke list will display it in a dialog.    See Edit a 
Joke for more information if you'd like to change a joke rather than just read it.



Having The Humor Mill Tell You a Random Joke Automatically
Having a tough day?    Need a little smile periodically as you try to muddle through?    You 
can configure The Humor Mill to automatically tell you a random joke from the collection 
contained in the loaded database periodically as long as it is running.    See the Startup 
Options entry for more information on setting up this configuration to suit you.



Browsing Sequentially Through the Jokes
Once you have a joke displayed, you will see a pair of buttons labeled "Next Joke" and 
"Previous Joke."    You can use these buttons to move sequentially through the joke records 
in the database currently loaded into the program.




